What browser do I need to use BigTent?

A browser is a software application for retrieving, presenting, and traversing information resources on the World Wide Web.Google Chrome version 30 and up.
 

  •  Google Chrome version 30 and up
  •  Firefox version 27 and up
  •  IE version 11
  •  Safari version 7 and up
Powered by Zendesk